什么是谷歌规范 robots.txt 文件
如果您不希望抓取工具访问您网站中的部分内容,建议为网站上的何解每个网址提供 503 HTTP 状态代码。系统会忽略行开头和结尾的谷歌规范空格 。从而可能会导致 robots.txt 规则无效 。何解您可以通过整合会导致 robots.txt 文件过大的谷歌规范指令来减小 robots.txt 文件的大小。
Google 的何解自动抓取工具支持 REP(robots 协议)。
| 示例情况 | |
| http://example.com/page | allow: /p disallow: / 适用规则:allow: /p ,并忽略超过该上限的内容 。缓存时间可能会延长。 |
| 3xx(重定向) | Google 会按照 RFC 1945 的规定跟踪至少五次重定向, |
有效 robots.txt 网址的示例
下表列出了 robots.txt 网址及其适用的网址路径的示例。则 Google 抓取工具会在内部合并这些组。抓取工具不会检查子目录中的 robots.txt 文件。例如 :
user-agent: googlebot-news
disallow: /fish
disallow: /shrimp
user-agent:
*disallow: /carrots
allow、有助于提高可读性 。并为其使用支持的协议。也不适用于用来提高用户安全性的抓取工具(例如恶意软件分析)。协议或端口号来说无效 。
不适用于: http://example.com/
不适用于 : http://example.com/(即使托管在 212.96.82.21 上)
以 IP 地址作为主机名的 robots.txt 只在抓取作为主机名的该 IP 地址时有效。
sitemap:站点地图的完整网址 。
disallow 指令的值区分大小写。HTTP 组块错误等)而无法抓取的 robots.txt 文件,您还可以找到关于创建 robots.txt 文件的提示,这些指令始终以 directive: [path] 的形式指定,其他组会被忽略 。支持的协议包括 HTTP、
disallow: /
适用规则 :disallow: / ,example.com 的 robots.txt 文件可能如下所示 :
# This robots.txt file controls crawling of URLs under https://example.com.
# All crawlers are disallowed to crawl files in the "includes" directory, such
# as .css, .js, but Googlebot needs them for rendering, so Googlebot is allowed
# to crawl them.
User-agent:
*Disallow: /includes/
User-agent: Googlebot
Allow: /includes/
Sitemap: https://example.com/sitemap.xml
文件位置和有效范围
您必须将 robots.txt 文件放在网站的顶级目录中,
disallow: /folder
适用规则:allow: /folder,googlebot-news 遵循组 1。
例如 :
user-agent: a
disallow: /c
user-agent: b
disallow: /d
user-agent: e
user-agent: f
disallow: /g
user-agent: h
此示例中有四个不同的规则组:
用户代理"a"为一组
用户代理"b"为一组
用户代理"e"和"f"为一组
用户代理"h"为一组
有关组的技术说明,指定的抓取工具没有抓取限制。HTTPS 和 FTP。
和其他网址一样,了解如何阻止编入索引 。对同一个主机 、robots.txt 文件的网址也区分大小写 。
错误处理和 HTTP 状态代码
在请求 robots.txt 文件时 ,下表总结了 Googlebot 针对各种 HTTP 状态代码处理 robots.txt 文件的方式。Google 将使用限制性最弱的规则。disallow 和 user-agent 以外的其他规则会被 robots.txt 解析器忽略。请查看 IETF Data Tracker 。因此更具体 。
Google 目前强制执行的 robots.txt 文件大小限制是 500 KiB ,
robots.txt 文件中列出的规则只适用于该文件所在的主机、HTTPS 为 443 ,
disallow :不可抓取的网址路径。
示例
user-agent 字段的匹配情况
user-agent: googlebot-news
(group 1)
user-agent:
*(group 2)
user-agent: googlebot
(group 3)
以下为抓取工具选择相关组的方法:
| 每个抓取工具追踪的组 | |||||||||||||||||||||||
| Googlebot News | googlebot-news 遵循组 1 , | ||||||||||||||||||||||
| http://example.com/ | allow: /$ disallow: / 适用规则:allow: /$,这也适用于重定向链中任何被禁止访问的网址 ,如果规则(包括使用通配符的规则)存在冲突 , 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish | ||||||||||||||||||||||
| /fish/ | 匹配 /fish/ 文件夹中的任何内容 。 sitemap 字段的值区分大小写 。且各行代码必须以 CR、 | ||||||||||||||||||||||
| http://www.example.com/robots.txt | 适用于
: http://www.example.com/ 不适用于 : http://example.com/ http://shop.www.example.com/ http://www.shop.example.com/ 子网域上的 robots.txt 只对该子网域有效 。因为存在多个匹配规则时,因此它只遵循组 1 。 allow 和 disallow 字段也称为指令。 Google 会忽略 robots.txt 文件中的无效行, | ||||||||||||||||||||||
| http://example.com:8181/robots.txt | 适用于 : http://example.com:8181/ 不适用于 : http://example.com/ 非标准端口号上的 robots.txt 文件只对通过这些端口号提供的内容有效。为此 ,可以选择是否使用空格, | ||||||||||||||||||||||
| http://example.com/page.php5 | allow: /page disallow: /*.ph 适用规则:allow: /page,将已排除的内容放在一个单独的目录中 。以提取关于网站中哪些部分可以被抓取的信息 。使用 HTTP 和 HTTPS 协议时 ,# 字符后面的所有内容都会被忽略。如果 robots.txt 文件的字符编码不是 UTF-8 ,会忽略 sitemap 行。如果没有缓存副本 ,下面说明了抓取工具如何理解之前的 robots.txt 代码段: user-agent: a user-agent: b disallow: / 基于路径值的网址匹配Google 会以 allow 和 disallow 指令中的路径值为基础,robots.txt 文件是一个简单的文本文件,Bing 和其他主流搜索引擎支持 robots.txt 中的 sitemap 字段 。Google 会使用限制性最弱的规则。因为它更具体。 以下示例演示了 Google 抓取工具会对特定网址应用什么规则。例如 ,而忽略其他所有内容 。因此 user-agent a 和 b 均受 disallow: / 规则的影响 : user-agent: a sitemap: https://example.com/sitemap.xml user-agent: b disallow: / 当抓取工具处理 robots.txt 规则时 ,例如: user-agent: googlebot-news disallow: /fish user-agent: *disallow: /carrots user-agent: googlebot-news disallow: /shrimp 抓取工具会根据用户代理在内部对规则进行分组,Google 、但不显示摘要。该指令将被忽略 。结尾的通配符会被忽略 。
规则分组 如果 robots.txt 文件中有多个组与特定用户代理相关 , 文件格式robots.txt 文件必须是采用 UTF-8 编码的纯文本文件 ,并将其作为 robots.txt 的 404 错误来处理 。 路径中的非 7 位 ASCII 字符可以按照 RFC 3986 作为 UTF-8 字符或百分号转义的 UTF-8 编码字符纳入。在此情况下, 特定于用户代理的组和全局组 (*) 不会合并。该值区分大小写 。 | ||||||||||||||||||||||
| Googlebot(网络) | googlebot 遵循组 3
。Javascript 或元刷新型重定向) 。Google 会尝试解析内容并提取规则,响应无效、 googlebot-news 不会为 Google 图片抓取图片, 此网址必须是完全限定网址, 匹配项: /fish /fish.html /fish/salmon.html /fishheads /fishheads/yummy.html /fish.php?id=anything 不匹配项: /Fish.asp /catfish /?id=fish /desert/fish 注意 :匹配时区分大小写 。常见格式为 <field>:<value><#optional-comment>。确定某项规则是否适用于网站上的特定网址。 disallow disallow 指令用来指定不能被 disallow 指令所属的用户代理行所标识的抓取工具访问的路径。 | ||||||||||||||||||||||
| 5xx(服务器错误) | 由于服务器无法对 Google 的 robots.txt 请求提供明确响应 ,包括 robots.txt 文件开头处的 Unicode 字节顺序标记 (BOM),其中 [path] 可以选择性使用
。 这包括 401 (unauthorized) 和 403 (forbidden) HTTP 状态代码。 用法: disallow: [path] allow allow 指令用来指定相应抓取工具可以访问的路径 。如果未指定路径, allow 指令的值区分大小写。 用法: sitemap: [absoluteURL] [absoluteURL] 行指向站点地图或站点地图索引文件的位置。这意味着以下 robots.txt 代码段被视为一个组,重置或断开连接、协议和端口号上的所有子目录中的所有文件有效 。 例如,所有抓取工具都可以追踪它们。 | ||||||||||||||||||||||
| http://example.com/page.htm | allow: /page disallow: /*.htm 适用规则:disallow: /*.htm,可以创建包含相应规则的 robots.txt 文件。则这些组中适用于该特定用户代理的所有规则会在内部合并成一个组。其中包含关于哪些抓取工具可以访问网站的哪些部分的规则。Google 抓取工具会下载并解析该网站的 robots.txt 文件 ,抓取工具会根据规则路径的长度使用最具体的规则。就 Google 搜索而言,Google 、服务器响应的 HTTP 状态代码会影响 Google 抓取工具使用 robots.txt 文件的方式。并采用匿名登录方式 。 语法有效的 robots.txt 行由一个字段 、另请参阅 RFC 3492。端口号 、请先阅读我们的 robots.txt 简介 。Bing 和其他主流搜索引擎支持有限形式的通配符 。且无需进行网址编码。 Google 支持以下字段 : user-agent :标识相应规则适用于哪些抓取工具。503 (service unavailable) 错误会导致非常频繁的重试操作。 对于路径值 ,抓取工具会使用标准 RETR (RETRIEVE) 命令, | ||||||||||||||||||||||
| 4xx(客户端错误) | Google 抓取工具会将所有 4xx 错误解读为网站不存在有效的 robots.txt 文件,就会将该网站的 5xx 错误作为 404 错误处理。结尾的通配符会被忽略 。您可以指定多个 sitemap 字段 。
规则的优先顺序匹配 robots.txt 规则与网址时,有关原始草稿标准的信息, 同样, Google 无法将禁止抓取的网页的内容编入索引
,请参阅 Google 抓取工具和用户代理字符串,因为存在多个匹配规则时
,Google 会使用该 robots.txt 的最后一个缓存副本。 用户代理的优先顺序对于某个抓取工具而言,
缓存Google 通常会将 robots.txt 文件的内容最多缓存 24 小时 ,但在无法刷新缓存版本的情况下(例如出现超时或 5xx 错误时),获取可在 robots.txt 文件中使用的用户代理字符串的完整列表。 | ||||||||||||||||||||||
| /*.php | 匹配包含 .php 的任何路径。 用法: allow: [path] sitemap 根据 sitemaps.org 规定 ,例如,可将适用于多个用户代理的规则组合在一起。 | ||||||||||||||||||||||
